Back to overview
Degraded

AWS account provisioning

Apr 16 at 02:42pm UTC
Affected services
AWS Accounts

Resolved
Apr 29 at 07:00am UTC

We have reallocated older unused accounts into the general pool which has freed up significant amount capacity.

We are comfortable with the amount of capacity that we now have and are thus closing this incident. We continue to work with AWS to extend this quota further for future use. We are also closely monitoring the amount of available AWS accounts that we can allocate.

Updated
Apr 18 at 01:00pm UTC

We have freed up more AWS accounts in our pool to further mitigate the immediate issue. We're still working with AWS to increase our total capacity.

Created
Apr 16 at 02:42pm UTC

Provisioning extra AWS accounts is currently degraded.

We maintain a pool of AWS account that are ready to use. We have reached our AWS Account quota and thus cannot currently add more accounts to the per customer pool. This will only affect customers that are starting tracks that contain AWS Cloud Accounts to a volume that has not yet been tested for that customer before. Running tracks that can use an existing AWS account are not affected.

We have reached out to AWS to extend our Account quantity quota.