Intermittent SSL Certificate Provisioning Failures
Resolved
Aug 07 at 08:35am UTC
We're seeing that DNS-related metrics have returned to normal, and SSL certificate provisioning is functioning reliably again. While the immediate symptoms have subsided, our support case with the third-party provider remains open as we continue to monitor and validate stability, but at this time, no further customer impact is expected.
Thank you for your patience while we worked through this issue.
Affected services
Created
Aug 06 at 01:09pm UTC
We're currently experiencing sporadic SSL certificate provisioning issues due to instability with a third-party DNS provider we rely on for required DNS record creation.
We have an active support case open with the provider and are closely monitoring the situation. In parallel, we're also evaluating alternative solutions to mitigate the impact and improve reliability moving forward.
We sincerely apologize for the inconvenience and appreciate your patience as we work to resolve this.
Affected services